This project is read-only.

Lots of errors and warnings in the Event Log :(

Topics: User Forum
Oct 13, 2006 at 8:01 AM
Heya guys :)

CI still doesn't seem to work for us and i've started checking the event log (with v1.0.9) to help see if anything is noted.

well, lots of things in the event log :(

here's a sample of the ERROR events we're getting.
EventType clr20r3, P1 w3wp.exe, P2 6.0.3790.1830, P3 42435be1, P4 microsoft.teamfoundation.versioncontrol.client, P5, P6 441132e8, P7 2f2, P8 2a4, P9 e14gfcc0mkyhh1tcoud1k2ynqervhd51, P10 NIL.

For more information, see Help and Support Center at


and this is logged after that...

An unhandled exception ('Microsoft.TeamFoundation.VersionControl.Client.WorkingFolderInUseException') occurred in w3wp.exe 4016. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.

Check the documentation index for 'Just-in-time debugging, errors' for more information.

For more information, see Help and Support Center at

those two event error logs hint to me that it's related to V1.0.9. Secondly, the errors didn't exist before i put Automaton on the single TFS server.

Also, the System event log lists this..

A process serving application pool 'TFSWSS' suffered a fatal communication error with the World Wide Web Publishing Service. The process id was '4052'. The data field contains the error number.

For more information, see Help and Support Center at

If i explore the Automaton virtual folder, it runs under the TFSWSS app process.

Lastly, if i manually try to do a build using the Automaton 'Tasks' button, it fails immediately. If i manually run my builds via VSTS, they work.

:( :( I'm going to have to uninstall V1.0.9 for the time being. it's a bit too unstable :(

Is there anything i could do to help get some debug info to you guys? I really love the product and the potential it has.
Oct 19, 2006 at 12:18 AM
This discussion has been copied to Work Item 4523. You may wish to continue further discussion there.
Oct 19, 2006 at 12:22 AM
Thanks for reporting these issues. I have tracked down some of the problems and they are currently being fixed.

One issue was that it was unable to get a workspace if you've had version installed earlier. We changed the way it named the auto-generated Workspace in version to include the machine name.

I have moved all new features away from the release and focus will be to fix any issues we see in the next few days and have new release more quickly than planned.
Nov 3, 2006 at 3:43 AM
Hi CareBear and krew,

just wanted to report back that seems to have solved this 'error log spam' problem. I'll be doing further testing of course but the initial testing looks good.

big thanks and so far love the new build :) (eg. enabling/disabling builds for a project!).