Doesn't start CI builds in 1011

Topics: User Forum
Nov 28, 2006 at 8:20 PM
Hi again,

I just installed 1011 and it fixed my previous issues (thanks!). However, I cannot get it to actually kick off a CI build. I went through and disabled CI builds for all my non-CI builds (note: the dashboard still shows all by builds with a gray background even when CI is disabled). My CI builds should then run triggered by checkins, but they do not. I can run builds manually via Automaton.

Since I installed the update I do get the following error in the Application event log which I assume is related to CI not working:

*********************************************************
Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Date: 11/28/2006
Time: 3:39:46 PM
User: N/A
Computer: BUILD
Description:
EventType clr20r3, P1 w3wp.exe, P2 6.0.3790.1830, P3 42435be1, P4 microsoft.teamfoundation.versioncontrol.client, P5 8.0.0.0, P6 441132e8, P7 7e1, P8 2c, P9 dbkrtyr501dkgnb2cja02sgu0rqe1k11, P10 NIL.
*********************************************************

I tried to recycle events in Automaton to see if it would help, but once I did that I would get an error in the Dashboard with corresponding messages in the event log (slightly scrubbed):

*********************************************************
Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Date: 11/28/2006
Time: 3:40:21 PM
User: N/A
Computer: BUILD
Description:
Faulting application w3wp.exe, version 6.0.3790.1830, faulting module kernel32.dll, version 5.2.3790.2756, fault address 0x00015e02.
*********************************************************
Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1309
Date: 11/28/2006
Time: 3:46:23 PM
User: N/A
Computer: BUILD
Description:
Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 11/28/2006 3:46:23 PM
Event time (UTC): 11/28/2006 8:46:23 PM
Event ID: 183468d7e6e14a0ea8bb23ecac1e0951
Event sequence: 16
Event occurrence: 1
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/Automaton-1-128092203289711297
Trust level: Full
Application Virtual Path: /Automaton
Application Path: C:\inetpub\wwwroot\Automaton\
Machine name: BUILD

Process information:
Process ID: 1752
Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: ArgumentException
Exception message: The directory name C:\Documents and Settings\ongle\Local Settings\Application Data\Microsoft\Team Foundation\1.0\Cache is invalid.

Request information:
Request URL: http://build/Automaton/default.aspx
Request path: /Automaton/default.aspx
User host address: 999.999.999.999
User: DOMAIN\ongle
Is authenticated: True
Authentication Type: Negotiate
Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
Thread ID: 1
Thread account name: NT AUTHORITY\NETWORK SERVICE
Is impersonating: False
Stack trace: at System.IO.FileSystemWatcher..ctor(String path, String filter)
at System.IO.FileSystemWatcher..ctor(String path)
at Microsoft.TeamFoundation.VersionControl.Client.Workstation..ctor(WorkstationType type)
at Microsoft.TeamFoundation.VersionControl.Client.Workstation.get_Current()
at Microsoft.TeamFoundation.VersionControl.Client.Client..ctor(VersionControlServer sourceControl)
at Microsoft.TeamFoundation.VersionControl.Client.VersionControlServer.Microsoft.TeamFoundation.Client.ITeamFoundationServerObject.Initialize(TeamFoundationServer tfs)
at Microsoft.TeamFoundation.Client.TeamFoundationServer.CreateITFSObjectInstance(Type serviceType)
at Microsoft.TeamFoundation.Client.TeamFoundationServer.GetService(Type serviceType)
at TeamFoundationExtensions.BuildManager.get_VersionControl()
at TeamFoundationExtensions.BuildManager.ReloadBuilds()
at TeamFoundationExtensions.BuildManager.get_Builds()
at Automaton.Web.Dashboard.Default.Page_Load(Object sender, EventArgs e)
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
*********************************************************

So... I restarted IIS and the above error disappeared but a new message appeared in the event log and I came full circle with CI not kicking off and getting w3wp.exe errors.

*********************************************************
Event Type: Error
Event Source: TFS Build
Event Category: None
Event ID: 3000
Date: 11/28/2006
Time: 3:53:44 PM
User: N/A
Computer: BUILD
Description:
TF53010: An unexpected condition has occurred in a Team Foundation component. The information contained here should be made available to your site administrative staff.
Technical Information (for the administrative staff):
Date (UTC): 11/28/2006 8:53:44 PM
Machine: BUILD
Application Domain: msbuild.exe
Assembly: Microsoft.TeamFoundation.Build.Common, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a; v2.0.50727
Process Details:
Process Name: MSBuild
Process Id: 3688
Thread Id: 404
Account name: DOMAIN\TFSACCOUNT

Detailed Message: The input data does not conform to the database schema. Please provide proper input.
Exception Message: The input data does not conform to the database schema. Please provide proper input. (type SoapException)

Exception Stack Trace: at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.TeamFoundation.Build.Proxy.BuildStore.AddChangeSetsForBuild(String buildUri, ChangeSetData[] changesets)
at Microsoft.TeamFoundation.Build.BuildLogger.LogChangesetEvent(Object sender, BuildMessageEventArgs args)
*********************************************************


Any ideas?

Coordinator
Dec 4, 2006 at 8:52 AM
I will investigate the issue, but please first try to delete the Team System cache folder in the profile:

C:\Documents and Settings\ongle\Local Settings\Application Data\Microsoft\Team Foundation\1.0\Cache
Dec 19, 2006 at 11:30 AM
I'm getting the same error. I have a new installation (not an upgrade). I've cycled IIS, restarted the machine, and cleared the Cache.

Each time a check in is made, it is appearently sensed, but the event log reports: "aspnet_wp.exe (PID: 3620) stopped unexpectedly.".

Curt Zarger